Page 2 of 11 FirstFirst 1234 ... LastLast
Results 21 to 40 of 215

Thread: waialaeboy's '07 Reppie...

  1. #21
    Mayor of Imitation waialaeboy's Avatar
    Join Date
    Feb 2011
    Location
    In the 5-0 suckas...
    Posts
    6,910

    Name: Shane
    VIN: 07/0286

    Default Re: waialaeboy's '07 Reppie...

    Quote Originally Posted by Repsol Dave View Post
    Nice going Shane! Very cool. What are ya scheming on next? Cause I could always use idea's.
    Thanks Dave! Yep, scheming, always scheming...

    Next up, imma finish cleaning up her rear end. Imma do the rear brake reservoir mod and grind off the hanger on the subframe. Meanwhile, I'll do the Nikky mod since I got the dremmel tool out. Still on the fence about doing the rear caliper relocator mod (the Rene special) but I'm gonna jump on some colored brake lines. I wish the CTS rotors were still around to cause I get a chubby everytime I see a set on someone's Rep...
    Quote Originally Posted by Repsol Dave View Post
    Long live the Magnificent '07!!! ()
    Quote Originally Posted by ddgith
    I think an 07 guy should have to pay triple the value, since "yours is the 'sweetest' machine"

  2. #22
    Margarita Peace Keeper Thrasher's Avatar
    Join Date
    Mar 2007
    Location
    MOTO GP PADDOCK
    Posts
    8,214

    Name: Thrasher
    VIN: 2007/0049

    Default Re: waialaeboy's '07 Reppie...

    Quote Originally Posted by waialaeboy View Post
    Can't do it George. Those mirrors/signals make me want to


    But I do need to hit you up for advice on your 'EPSO' sticker for your Puig DB screen. A black one is going on soon.

    Also, thanks everyone for all the positive vibes. My buddy was just as excited for me whist we were putting in work last night and I consider his Blade a 'God among men' level bike...!

    Mods make me so happy...!
    Dude whats up, Those mirrors are the Mutts Nuts, The ShizzNitzs
    “Calling upon my years of experience, I froze at the controls.”
    – Stirling Moss
    The Sun Never Sets on the 07 Empire!

  3. #23
    Margarita Peace Keeper Thrasher's Avatar
    Join Date
    Mar 2007
    Location
    MOTO GP PADDOCK
    Posts
    8,214

    Name: Thrasher
    VIN: 2007/0049

    Thumbs up Re: waialaeboy's '07 Reppie...

    “Calling upon my years of experience, I froze at the controls.”
    – Stirling Moss
    The Sun Never Sets on the 07 Empire!

  4. #24
    Mayor of Imitation waialaeboy's Avatar
    Join Date
    Feb 2011
    Location
    In the 5-0 suckas...
    Posts
    6,910

    Name: Shane
    VIN: 07/0286

    Default Re: waialaeboy's '07 Reppie...

    Quote Originally Posted by Thrasher View Post
    Bwahahahahahaha...!!!

    "Look if you don't buy this, I will kill YOU...!"

    Quote Originally Posted by Repsol Dave View Post
    Long live the Magnificent '07!!! ()
    Quote Originally Posted by ddgith
    I think an 07 guy should have to pay triple the value, since "yours is the 'sweetest' machine"

  5. #25
    Senior Member johnny repsol's Avatar
    Join Date
    May 2010
    Location
    ma
    Posts
    857

    Name: john
    VIN: 09 #00590

    Default Re: waialaeboy's '07 Reppie...

    Congrats on your upgrades. Why did the previous owner not done these, or ANYTHING? It shows that you have more love for it. it deserves you. Today, i will complete my mods. Have not rode since last July!!!!!




    ALOHA

  6. #26
    Master of '09 Hotness! Repsol Dave's Avatar
    Join Date
    Mar 2011
    Location
    Lost.......As usual
    Posts
    5,597

    Name: Dave
    VIN: 2009 #00240

    Default Re: waialaeboy's '07 Reppie...

    Quote Originally Posted by waialaeboy View Post
    Thanks Dave! Yep, scheming, always scheming...

    Next up, imma finish cleaning up her rear end. Imma do the rear brake reservoir mod and grind off the hanger on the subframe. Meanwhile, I'll do the Nikky mod since I got the dremmel tool out. Still on the fence about doing the rear caliper relocator mod (the Rene special) but I'm gonna jump on some colored brake lines. I wish the CTS rotors were still around to cause I get a chubby everytime I see a set on someone's Rep...
    Right on! mod that puppy up!!! I just spent my sisters wedding present money some parts. Oops!! Oh well I'll make it up to her.....hahaha
    Quote Originally Posted by waialaeboy View Post
    ..............Maybe you shoulda picked up an '09...:
    The Sun Never Sets on the '09 Empire!
    RIDE LIKE DAVE!

  7. #27
    Rookie Member FireBall's Avatar
    Join Date
    Apr 2011
    Location
    Springfield MO
    Posts
    103

    Name: Alex
    VIN: 2005-#00217

    Default Re: waialaeboy's '07 Reppie...

    Maybe I missed it, but what Brand Headlight kit? Going to be ordering one soon! Still your first choice?

  8. #28
    Mayor of Imitation waialaeboy's Avatar
    Join Date
    Feb 2011
    Location
    In the 5-0 suckas...
    Posts
    6,910

    Name: Shane
    VIN: 07/0286

    Default Re: waialaeboy's '07 Reppie...

    Quote Originally Posted by FireBall View Post
    Maybe I missed it, but what Brand Headlight kit? Going to be ordering one soon! Still your first choice?
    HID brand is Xentec. Looks very professional, was plug and play. Very simple install. Just gotta work out my ignite issue. We are gonna start with replacing my stock 'weak' battery with a Shorai when they start shipping from Japan next month. Meanwhile here is a link to for updated pictures...

    http://www.repsolforum.com/forums/album.php?albumid=532
    Quote Originally Posted by Repsol Dave View Post
    Long live the Magnificent '07!!! ()
    Quote Originally Posted by ddgith
    I think an 07 guy should have to pay triple the value, since "yours is the 'sweetest' machine"

  9. #29
    Novice Member Maple1's Avatar
    Join Date
    Feb 2011
    Location
    Wichita Falls, TX
    Posts
    337

    Name: Aitken
    VIN: 00910/0031

    Default Re: waialaeboy's '07 Reppie...

    Quote Originally Posted by waialaeboy View Post
    HID brand is Xentec. Looks very professional, was plug and play. Very simple install. Just gotta work out my ignite issue. We are gonna start with replacing my stock 'weak' battery with a Shorai when they start shipping from Japan next month. Meanwhile here is a link to for updated pictures...

    http://www.repsolforum.com/forums/album.php?albumid=532
    Me to, i am in the market for some nice HID's.

    Last time mine keep shorting out, and the bike would never start after it., So I took them out eventuality.
    2013 Repsol #0031
    2007 Repsol #0910
    My Other Ride:F-16C Falcon

  10. #30
    Rookie Member FireBall's Avatar
    Join Date
    Apr 2011
    Location
    Springfield MO
    Posts
    103

    Name: Alex
    VIN: 2005-#00217

    Default Re: waialaeboy's '07 Reppie...

    Quote Originally Posted by waialaeboy View Post
    HID brand is Xentec. Looks very professional, was plug and play. Very simple install. Just gotta work out my ignite issue. We are gonna start with replacing my stock 'weak' battery with a Shorai when they start shipping from Japan next month. Meanwhile here is a link to for updated pictures...

    http://www.repsolforum.com/forums/album.php?albumid=532
    Ya, keep us posted on what solves your ignite issue?
    05' Repsol with a two shepherd security system!

  11. #31
    Mayor of Imitation waialaeboy's Avatar
    Join Date
    Feb 2011
    Location
    In the 5-0 suckas...
    Posts
    6,910

    Name: Shane
    VIN: 07/0286

    Default Re: waialaeboy's '07 Reppie...

    Quote Originally Posted by FireBall View Post
    Ya, keep us posted on what solves your ignite issue?
    Well FB, it's gonna be a minimum of a few weeks before I get a chance to find out...

    Here's why:
    1) Due to the earthquake/tsunami in Japan Shorai has halted shipping and will resume around mid-May,
    2) Taking my fam to Vegas for 2-weeks starting May 4

    Meanwhile, after talking to the supplier it seems most feasible that the weak/4-year old stock Yuasa battery is the culprit. The HID's suck up a TON of energy to fire up and requires a fully charged 12V at minimum. We are going to try and fully charge my stock battery with a trickle charger and hopefully she'll ignite the HID's properly. If not, the second culprit is a faulty ballast. I'll keep you updated...
    Quote Originally Posted by Repsol Dave View Post
    Long live the Magnificent '07!!! ()
    Quote Originally Posted by ddgith
    I think an 07 guy should have to pay triple the value, since "yours is the 'sweetest' machine"

  12. #32
    Master Yoda rene's Avatar
    Join Date
    Feb 2008
    Location
    The Netherlands
    Posts
    7,598

    Name: REPSOL RENE
    VIN: 2005 / #01604

    Default Re: waialaeboy's '07 Reppie...

    Quote Originally Posted by waialaeboy View Post
    HID brand is Xentec. Looks very professional, was plug and play. Very simple install. Just gotta work out my ignite issue. We are gonna start with replacing my stock 'weak' battery with a Shorai when they start shipping from Japan next month. Meanwhile here is a link to for updated pictures...

    http://www.repsolforum.com/forums/album.php?albumid=532
    I think it's because you are talking bad about the mother of the '07......yep the one and only '05

  13. #33
    Mayor of Imitation waialaeboy's Avatar
    Join Date
    Feb 2011
    Location
    In the 5-0 suckas...
    Posts
    6,910

    Name: Shane
    VIN: 07/0286

    Default Re: waialaeboy's '07 Reppie...

    Okay people I'm back from Sin City. I've been drooling over all the parts that arrived while we were on vacation.

    Quick story about catching a chubby: One day we drove out to Logandale Trails from Vegas (45-50 miles NE of Vegas) to catch a quick strike dirtbike mission. My bro-in-law drove us through an awesome 50-miles of twisties called North Shore Drive. I never wanted to be on my Reppie so badly! The wide, two-way roads are freshly paved with nice wide shoulders and none of that bumpy crap in the center strip.

    Now, on to the mods!

    Parts that came in:
    1) Puig DB Windscreen (Black) installed
    2) 'EPSO' Sticker installed
    3) G-Craft Rear Brake Reservoir installed, see post #40
    4) Shorai Battery installed
    5) BMC Race Air Filters installed

    Attachment 26706 Attachment 26707Attachment 26708

    Puig DB Windscreen/'EPSO' sticker (before, after, after-side view)

    Attachment 27446Attachment 27447

    Shorai Battery. Ridiculously light and super strong cranking

    Attachment 27448Attachment 27449Attachment 27450

    BMC Race Air Filters (stock, after, after 2)

    I have to add that with the air filters installed the Rep runs butter smooth. I haven't felt such a dramatic change in the ride since I did the 'flapper mod'.

    Special thanks to my bro Glenn, who not only installed the windscreen while I was on 'vacay' but did an awesome job on the 'EPSO' sticker...
    Last edited by waialaeboy; Oct 12th, 2011 at 03:29 AM.
    Quote Originally Posted by Repsol Dave View Post
    Long live the Magnificent '07!!! ()
    Quote Originally Posted by ddgith
    I think an 07 guy should have to pay triple the value, since "yours is the 'sweetest' machine"

  14. #34
    Mayor of Imitation waialaeboy's Avatar
    Join Date
    Feb 2011
    Location
    In the 5-0 suckas...
    Posts
    6,910

    Name: Shane
    VIN: 07/0286

    Default Re: waialaeboy's '07 Reppie...

    Quote Originally Posted by FireBall View Post
    Ya, keep us posted on what solves your ignite issue?
    Alright, here go the scenario with my Xentec 6000K HID ignite problem (problem = need to turn key to on postion 4-5 times to get the HID's to fire up and stay on)...

    1) New Shorai battery went in (that little battery is amazing!) Super light and cranks like a champ. Did not fix the problem.
    2) Exchanged slim style ballast with local Xentec dealer. New slim ballast installed. Did not fix the problem.
    3) Replaced new slim style ballast with older 'boxier' style ballast. Problem fixed. Or so I thought...

    Went for a short ride and my bike rode perfect for a few miles. Then... my bike began to spit, and then sputtered and that was followed by my control panel going blank only showing orange and then finally my bike died. Battery dead. We are now trouble shooting the charging system for obvious reasons. We suspect it is the regulator/rectifier, stator, overheated and burned wiring or a combination of either or all of the above. It seems the mighty '07 Reppie isn't immune to the '04 Blades Achilles heel (charging issues)...

    So although it seems the HID ignite problem was caused by the new slim style ballasts, the charging system failing probably has had something to do with the problem. The timing of the charging system failing at the same time as the HID install we're hoping is coincidental...

    UPDATE:

    Parts:
    Rick's Stator installed
    Rick's Regulator Rectifier installed

    Charging system up and running strong. Problem fixed

    HID working with non-slim ballast. Problem fixed
    Last edited by waialaeboy; Jun 30th, 2011 at 03:17 AM.
    Quote Originally Posted by Repsol Dave View Post
    Long live the Magnificent '07!!! ()
    Quote Originally Posted by ddgith
    I think an 07 guy should have to pay triple the value, since "yours is the 'sweetest' machine"

  15. #35
    Mayor of Imitation waialaeboy's Avatar
    Join Date
    Feb 2011
    Location
    In the 5-0 suckas...
    Posts
    6,910

    Name: Shane
    VIN: 07/0286

    Default Re: waialaeboy's '07 Reppie...

    Starting to bust out the bling...

    I've decided to go with anodized black and red for accents on my forward controls.

    Parts Installed:
    1) D3 Grips, anodized Black
    2) D3 Bar Ends, anodized Red

    Attachment 27451 Attachment 27454

    Left side handgrip and bar end (before & after)

    Attachment 27452 Click image for larger version. 

Name:	IMG_1545.jpg 
Views:	91 
Size:	196.1 KB 
ID:	27453

    Right side handgrip and bar end (before & after)

    Parts to Order:
    1) Pazzo Shorty Levers, Black w/red adjuster
    2) Pre-load adjusters (brand undecided), Black/Red

    This will complete the subtle bling that I want for my forward controls...
    Quote Originally Posted by Repsol Dave View Post
    Long live the Magnificent '07!!! ()
    Quote Originally Posted by ddgith
    I think an 07 guy should have to pay triple the value, since "yours is the 'sweetest' machine"

  16. #36
    Senior Member AexusEngineering's Avatar
    Join Date
    Jan 2010
    Location
    NYC & around
    Posts
    670

    Name: Aexus
    VIN: 09/ #1186

    Default Re: waialaeboy's '07 Reppie...

    Looks nice. And I LOVE the tiled garage. Tough to keep clean?

  17. #37
    Back for the Attack isaac920's Avatar
    Join Date
    Oct 2009
    Location
    upstate ny
    Posts
    2,579

    Name: isaac
    VIN: 2009#01205

    Default Re: waialaeboy's '07 Reppie...

    looking good shane
    life is truly amazing and i like the fact that i am not perfect LIVE LOVE LIFE

  18. #38
    Mayor of Imitation waialaeboy's Avatar
    Join Date
    Feb 2011
    Location
    In the 5-0 suckas...
    Posts
    6,910

    Name: Shane
    VIN: 07/0286

    Default Re: waialaeboy's '07 Reppie...

    Quote Originally Posted by AexusEngineering View Post
    Looks nice. And I LOVE the tiled garage. Tough to keep clean?
    It's my buddy Glenn's mancave. It's pretty ridiculous in there. A bunch if us keep our bikes there and we do most of our 'skunkwerk' operations out of his garage.

    The tile is fairly new. It's holding up pretty well and seems to clean easily. Blower for all the dust and dog hair and spills are easily wiped up. Prior to the tile, he had layed some epoxy-type gararge floor covering. Even after multiple tries and repair, that one was terrible.

    Quote Originally Posted by isaac920
    looking good shane
    Thanks mang! Just doing my own thing cause there's no way I'm "keeping up with the Jones'es" from this forum, if you know what I'm sayin'...!
    Quote Originally Posted by Repsol Dave View Post
    Long live the Magnificent '07!!! ()
    Quote Originally Posted by ddgith
    I think an 07 guy should have to pay triple the value, since "yours is the 'sweetest' machine"

  19. #39
    Mayor of Imitation waialaeboy's Avatar
    Join Date
    Feb 2011
    Location
    In the 5-0 suckas...
    Posts
    6,910

    Name: Shane
    VIN: 07/0286

    Default Re: waialaeboy's '07 Reppie...

    Purchased the 3M 1080 Auto Film a few weeks ago and finally got around to wrapping a few pieces.

    Even after watching a few of the sped up video installs I b!tched out on doing them myself. Instead of screwing the pooch with the film, like how I sometimes tend to do, I opted to recruit professional help. Luckily my good buddies install paint protection film and are perfectionists.

    Here's the results...

    Attachment 27772Attachment 27773

    Gas Tank Infill Right Side 1 (before) & (after)

    Attachment 27774Attachment 27775

    Gas Tank Infill Right Side 2 (before) & (after)

    Attachment 27776Attachment 27777

    Heat Shield (before) & (after)

    Attachment 27778Attachment 27779

    Rear Hugger
    Last edited by waialaeboy; Sep 24th, 2012 at 02:37 AM.
    Quote Originally Posted by Repsol Dave View Post
    Long live the Magnificent '07!!! ()
    Quote Originally Posted by ddgith
    I think an 07 guy should have to pay triple the value, since "yours is the 'sweetest' machine"

  20. #40
    Mayor of Imitation waialaeboy's Avatar
    Join Date
    Feb 2011
    Location
    In the 5-0 suckas...
    Posts
    6,910

    Name: Shane
    VIN: 07/0286

    Default Re: waialaeboy's '07 Reppie...

    Back at the bro-cave and up to some more skunk-werks! Some more bling-bling and an actual performance mod...

    Finally did the flipped rear caliper mod. Special thanks to Rene (who really is brilliant to design a mod like this) and Mike @ FP Racing for pretty much being an awesome guy to deal with.

    On with the show...

    Attachment 29189 Attachment 29191
    Stock Rear Caliper (before) & Rene Design/FP Racing Rear Caliper Relocator (after)


    Attachment 29190 Attachment 29192 Attachment 29193
    Stock Resevoir (before) & G-Craft (replica) Reservoir (anodized Black), Speigler Brakeline (Red line/anodized Gold Banjo), Grinded Subframe (after 1 and 2)


    Attachment 29194
    Speigler Front Brakelines (Red line/anodized Gold Banjo)
    Last edited by waialaeboy; Oct 12th, 2011 at 04:05 AM.
    Quote Originally Posted by Repsol Dave View Post
    Long live the Magnificent '07!!! ()
    Quote Originally Posted by ddgith
    I think an 07 guy should have to pay triple the value, since "yours is the 'sweetest' machine"

Page 2 of 11 FirstFirst 1234 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

You can help to support this site by making a donation below
(even a small donation makes a big difference)
 
Make payments with PayPal - it's fast, free and secure!